Sharepoint site collection administrator lost full permission issue

Problem

Today I faced a strange problem in SharePoint 2010.

It happened all of a sudden that permission has been lost for all the users on specific site collection, however i tried to login by the farm admin and site collection admin but i don’t have administrator permissions so i can’t add users or add user. Just i see the site but i can’t do any operation this problem just happened on one site collection but other site collection working well

Symptoms

Resolution

Run the below command to know the status of your web application content database

stsadm -o getsitelock -url [site]

Reference: http://technet.microsoft.com/en-us/library/cc262915.aspx

If the command returns as “Read-only” you will need to change to “None” to unlock database.

stsadm -o setsitelock -url http://server_name -lock none

Reference: http://technet.microsoft.com/en-us/library/cc262811.aspx

7 thoughts on “Sharepoint site collection administrator lost full permission issue

  1. Thank you very much.
    I dont know how my site got locked because of this I am unable to deploy solution.
    After following your steps site got unlocked and able to deploy solution.

    Thank you once again.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.